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Introduction 

 

 

 

About GMM 

 

GMM（Genotype Matrix Mapping）is a computer program for    the detection of QTLs 

(Quantitative Trait Loci) and QTL interactions in genetic variation from comparisons of 

genotypic and phenotypic data. The central approach in GMM is the following: 

 

・ Each tested marker is given a virtual matrix (GM) containing intersecting lines and rows 

equal to the total number of alleles for the marker in the population analyzed. 

・ QTL interactions are then estimated and compared through virtual networks among the 

GMs. 

 

RefRefRefReferenceerenceerenceerence 

S. Isobe, A. Nakaya and S. Tabata. Genotype Matrix Mapping (GMM): Searching for QTL 

interactions in genetic variation in complex traits. (2007) DNA Research 14:217-225. 

 

Hardware requirements are listed in Table 1-1.  

 

Table 1-1 Hardware requirements 

 WindowsWindowsWindowsWindows    Mac OS XMac OS XMac OS XMac OS X    

CPU Pentium4 or later version PPC or Intel 

Memory >512 MB 

Hard disk >100 MB 

OS Version XP or later version 10.4 or later version 

 

Large scale data analysis by Windows 32 bit often causes to stop program execution because of 

running out of memory. We recommend using Windows 64 bit or Mac for large scale data 

analysis. 
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Chapter 1 Installation 

 

1111----1.1.1.1. WindowsWindowsWindowsWindows    
 

1. Start up the downloaded file (install.exe) 

by double-clicking on the icon. 

 

 

 

 

 

 

 

 

 

 

2. After the installation preparation is 

finished, the screen at right is 

displayed. Click on the [OK] button, 

and then go to the next step.  

 

 

 

 

 

 

 

 

 

3. The Introduction is displayed. 

Click on the [Next] button to 

go to the next step. 
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4. Choose the install folder. To 

change the folder from the 

default setting, click on the 

[Choose] button.  

 

 

 

 

 

 

 

 

 

 

5. Choose the shortcut folder. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

6. The Pre-installation summary 

is displayed. Confirm that the 

summary details are correct, 

and then start installation by 

clicking on the [Install] button.  
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7. The installation progress is 

displayed.  

 

 

 

 

 

 

 

 

 

 

 

 

8. After the installation is 

finished, the screen at right is 

displayed. Click on the [Done] 

button to complete the 

installation. 
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1111----2.2.2.2.     Mac OS XMac OS XMac OS XMac OS X    
        

 

 

1. Unpack the downloaded file 

[install.zip] by double clicking. 

Then start the generated 

installer by double clicking. 

 

 

 

 

 

 

2. After the installation preparation 

is finished, the screen at right is 

displayed. Click on the [OK] 

button to go to the next step.  

 

 

 

 

 

 

 

 

 

 

3. The Introduction is displayed. 

Click on the [Next] button to 

go to the next step.  
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4. The Introduction is displayed. 

Click on the [Next] button to 

go to the next step.  

 

 

 

 

 

 

 

 

 

 

 

5. Choose the alias folder. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

6.  The pre-installation summary 

is displayed. Confirm that the 

summary details are correct, 

and then start installation by 

clicking on the [Install] button.  
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7. The installation progress is 

displayed.  

 

 

 

 

 

 

 

 

 

 

 

8. After the installation is 

finished, the screen at right 

is displayed. Click on the 

[Done] button to complete 

the installation. 
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Chapter 2  Using GMM 

  

    
2222----1. 1. 1. 1. GeneralGeneralGeneralGeneral    

 

 

The GMM display consists of the following five components: 

 

 

 

(1) The Menu bar contains the operations menu.  

(2) The Data Window contains a loaded data set. 

(3) The Result Window contains a list of analysis results. 

(4) The Matrix Window contains aaaanalysis results in the form of Genetic Matrixes. 

(5) The Circle Window contains analysis results on linkage groups. 

 

(3) Result Window 

(2) Data Window 

(4) Matrix Window 

(5) Circle Window 

(1) Menu bar 
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2222----2.2.2.2.    Menu barMenu barMenu barMenu bar    
 

 

The menu consists of the following three components.  Edit menu is not available now. 

 

1. File menu  

2. Analyze menu  

3. Help menu  

 

 

 

 

 

1. File menu 

New Load and analyze a new data set. 

Open Open an existing file. 

Save Save contents as a GMM file. 

Save As Save contents with a new file name. 

Save Image Save a screen image of a Matrix or Circle 

window as an image file (PNG or EPS). 

Exit Close the GMM program. 

 

 

 

 

2. Analyze Menu 

Reanalyze Reanalyze the uploaded data with   

different conditions. 

 

 

 

 

 

3. Help Menu 

Sample Open a sample data set. 

About Information about GMM.  
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2222----3.3.3.3.    DataDataDataData    windowwindowwindowwindow    
 

The Data window displays phenotypic and genotypic data used for the analysis. Each line 

indicates information about an individual sample.  

   

 

 

First column    Sample name 

Second column   Phenotypic data 

Third and subsequent columns            Genotypic data 

 

For missing data, use ‘∗’ as a missing code.  The code, ‘∗’, is excluded from 

analysis.     
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2222----4.4.4.4.    ResultResultResultResult    wwwwindowindowindowindow    

 

 

The Result window holds a list of analysis results. The version of the program and the 

analysis conditions are displayed on the upper bars. 

 

 

F F value 

Num. (True) Number of samples that correspond to the detected locus (allele). 

Ave. (True) Mean value of the samples that correspond to the detected locus (allele). 

Num. (False) Number of samples that do not correspond to the detected locus (allele). 

Ave. (False) Mean value of the samples that do not correspond to the detected locus 

(allele). 

MSA Between-class variance 

MSW Within-class variance 

MST Total variance 

Length Number of loci that make up the detected combination. 

Locus (allele) Names of loci and alleles. 
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2222----5.5.5.5.    MatrixMatrixMatrixMatrix    windowwindowwindowwindow    

 

The Matrix window holds results of analyses in the form of Genetic Matrixes.  

 

Matrix  Each matrix indicates one marker. Each cell in a matrix indicates a 

single QTL effect. The F value (magnitude of a single QTL effect) is 

represented with shades of blue. 

 

Line                  Lines between cells indicate combinations of QTLs. The F value 

(magnitude of QTL interactions) is represented with colors from 

yellow to red. 

 

Display Threshold Displayed lines and the cells they connect are refined based on a 

set threshold. 

 

Set Locus Displayed matrixes that interact with the selected cells are refined. 
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2222----6.6.6.6.    CircleCircleCircleCircle    windowwindowwindowwindow    

 

The Circle window displays analysis results as a circle of linkage groups. This window 

is not displayed if map information is not loaded. 

 

 

Linkage circle All linkage groups are displayed on a circle, and the interacting QTLs are 

indicated inside of the circle. 

Inside lines The inside lines indicate relationships between interacting QTLs. The color 

of each line, from yellow to red, represents the magnitude of the F value 

(strength of the QTL interaction). 

Zoom Sets the size of the linkage circle. 

LG Width Sets the width of the linkage circle. 

Font Size Sets the font size. 
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Chapter 3  Tutorial  

 

3333----1.1.1.1.    Start upStart upStart upStart up    
 

<<<<WindowsWindowsWindowsWindows>>>>    

 Select <all programs→GMM→GMM> 

on the Start Menu or double click on the 

GMM icon. 

 

 

 

<<<<Mac OS XMac OS XMac OS XMac OS X>>>>    

    

 Double click on the [GMM Alias] icon. 

 

 

 

If an alias was not created at installation, 

start GMM from within the GMM folder.  

 

 

 

 

 

 

    
    
3333----2.2.2.2.    ExitExitExitExit    

 Select <File→Exit> on the Menu bar. 
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3333----3.3.3.3.    Data analysisData analysisData analysisData analysis    
 

1. Select  <File→New> from the Menu bar. 

 

 

 

 

 

 

 

 

 

2. The screen at right is displayed. Click on the 

[Select] button. 

 

 

 

 

 

 

 

 

 

 

3. The Load Data dialog is displayed. Choose the 

data file, and then click on the [Open] button. 

 

The data file must be saved as a tab-delimited text 

file. Use two characters for the genotype code and 

numerals for phenotypic data. 

 

A sample data file can be found in the GMM/sample 

folder (Sampledata.PM). 

 

4. The chosen file is loaded and displayed in the data 

window. 
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5. Set a data set. 

 

Press the uppermost marker 

name in the <First Marker> 

pulldown menu. 

 

The column headings  for the 

selected marker and the 

markers to its right are 

colored pink, and the data in 

the columns are defined as a 

genotypic data set.  

 

 

Select the uppermost sample 

name in the <First Sample> 

pulldown menu. 

 

The column headings for the 

selected sample and the 

samples below it are colored 

aqua and defined as a set of 

sample data.  

 

 

 

Select the phenotype data 

from the list in the <Target 

Trait> pulldown menu. 

 

The column heading for the 

selected cell is colored red, 

and the data in the column 

are defined as phenotypic 

data. 

 

 

Press the [Select] button to 

complete the procedure. 
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6. Loading map information. 

The <Select Linkage Map Data> window is 

displayed. If there is no map information, select [Not 

Exists] and then press [OK]. 

 

 

 

 

 

 

 

If map information is available, select <File Exists>, 

and then press the [Select] button. 

The Load Linkage Map dialog is opened. Set a map 

file and press the [Open] button. After selecting the 

map file, press the [OK] button.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The map file must be must be saved as a  

tab-delimited text file. Input data as follows: 

 

#<Linkage group name> <total length> 

<Marker name1> <map position> 

<Marker name2> <map position> 

 

Shown in the figure at right. 

 

The sample data are saved in the GMM/sample folder as 

sampledata_map.DAT. 

#LG1 136.7
RCS2183 43.723
RCS0005 56.013
RCS0089 92.005
#LG2 149.7
RCS0130 10.551
RCS1708 35.664
RCS1300 39.853
RCS1113 44.200
RCS1285 47.710
#LG-NA 3
RCS0235 2.0
#LG-NA 3
RCS1366 2.0
#LG-NA 3
RCS3719 2.0
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7. Parameter settings. 

The <Set Parameter> window is 

displayed. 

Set the following three parameters, and 

then press the [Calculate] button. 

 

 

 

 

 

 

 

Max Length of Locus Combination Maximum number of analyzed marker 

combinations. If “1” is selected, GMM calculates a 

single QTL effect. If “3” is selected, GMM 

calculates a maximum of three marker 

combinations.  

Min Number of Corresponding Minimum number of samples that meet the 

conditions. 

Search Range Search range for the calculation.  

Automatic                      To set the search range automatically, check 

[Automatic]. 

 

8. The  screen shown at right is displayed during the 

calculation. Please wait. 

 

 

 

 

9. After the calculation, the result windows 

are displayed.  
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3333----4.4.4.4.    Data reanalysisData reanalysisData reanalysisData reanalysis    
 

 

1. Select <Analyze→Reanalyze> on the Menu bar. 

 

 

 

 

 

 

 

 

2. Set Parameters. 

Follow the instructions in “Section 3-3. Data 

analysis”. Then click on the [Calculate] button. 

 

 

 

 

 

 

 

3. Please wait.  

 

 

 

 

 

 

 

 

4. The Data reanalysis is complete. 
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3333----5.5.5.5.    Save resultsSave resultsSave resultsSave results    
 

 The analysis results can be saved as a project file (.gmm). 

 

 

1. Select <File→Save> or <File→Save As> on the 

Menu bar. 

 

 

 

 

 

 

 

 

 

 

 

2. Input a file name in the dialog box, and then click 

on the [Save] button. 
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3333----6666    Distribution ofDistribution ofDistribution ofDistribution of    phenotypic dataphenotypic dataphenotypic dataphenotypic data    
 

 GMM displays the distribution of phenotypic data of the selected locus/allele. 

 

Select a Data cellSelect a Data cellSelect a Data cellSelect a Data cell....    

 Double click on a genotypic data cell in the 

Data window. The distribution of phenotypic 

data is indicated in a new window (Red: 

selected locus/allele, Blue: unselected 

loci/alleles). 

 

 

 

 

 

 

 

 

 

 

 

 

 

Select a cell Select a cell Select a cell Select a cell iiiin a n a n a n a MatrixMatrixMatrixMatrix....    

 Double click on a cell in a Matrix window. The 

distribution of phenotypic data is indicated in a 

new window (Red: selected locus/allele, Blue: 

unselected loci/alleles). 
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Select a line Select a line Select a line Select a line connectingconnectingconnectingconnecting    MatrixesMatrixesMatrixesMatrixes        

  Double click on a line in a Matrix window. 

The distribution of phenotypic data is shown in 

a new window (Red: locus/allele related to the 

selected line (combination), Blue: loci/alleles not 

related to the selected line).  
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3333----7.7.7.7.    RefiningRefiningRefiningRefining    
 Once a calculation is completed, all identified loci (markers) are indicated in the Matrix 

window. GMM allows you to limit the display to a selected combination of identified loci in a 

new window by using the Refining function. 

 

 

Line refiningLine refiningLine refiningLine refining    

Set the threshold [F], and then click on 

the [Submit] button. 

Only lines corresponding to the upper 

bound threshold [F] value are displayed. 
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Matrix refiningMatrix refiningMatrix refiningMatrix refining    

    

 

Click on a cell, and the selected Locus (allele) is 

indicated on the left side. Only cells generating 

connection lines can be selected.  

 

 

R indicates the number of displayed 

combinations. Set <R> and click on the [Submit] 

button. The matrixes connected to the selected 

cell are indicated by lines in a new window. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Case of <R=2> 

Case of <R=1>  
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Circle refining Circle refining Circle refining Circle refining     

Double click an internal line in a 

linkage circle. The corresponding loci 

are indicated in a new matrix window. 
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3333----8.8.8.8.    Change the dChange the dChange the dChange the display of a circle windowisplay of a circle windowisplay of a circle windowisplay of a circle window    
 

 You can change the size, width and fonts of a linkage Circle.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The [Zoom] slider is used for scaling the linkage circle. 

 

[LG Width] is used for changing the width of a linkage circle.  

[Font Size] is used for changing the font size. 
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3333----9.9.9.9.    Save imageSave imageSave imageSave image    
 

Pictures in the Matrix window and Circle window can be saved as image files. 

 

1. Select <File→Save Image> from the Menu bar. 

 

 

 

 

 

 

 

 

 

2. The File dialog is displayed. 

Name the file and select the file type (.eps or .png), 

and then click on the [Save] button. 

 

 

 

 

 

 

 

3. The image file is saved in the selected folder.  
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3333----10.10.10.10.    Display of sample dataDisplay of sample dataDisplay of sample dataDisplay of sample data    
 

You can explore how GMM functions by consulting the included sample data. 

 

 

1. Select <Help→Sample> on the Menu bar. 

 

 

 

 

 

 

 

 

2. The analyzed sample data are displayed. 
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3333----11.11.11.11.    Invoking multiple instancesInvoking multiple instancesInvoking multiple instancesInvoking multiple instances    on on on on MacMacMacMac    
 

 Generally, invoking multiple instancesis not allowed on Mac OS X, because of restrictions 

in the OS. To invoke multiple instances of  GMM  on Mac OS X, double-click on ‘GMM dup’ 

included in the GMM folder.  

 

  

 

 

 

 

 

 

 

 


